登陆
浏览模式: 标准 | 列表 Tag: 编译

in the prefix, you've chosen, are n...

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

嘿嘿

sudo apt-get install kdelibs4-dev

就可以解决了。。。自己找的包包哦

现在还在编译compizconfig-backend-kconfig-0.6.0这个文件夹呢~~~~

Tags: ubuntu, compiz, 编译

No package 'gconf-2.0' found

我都佩服我自己了 又被自己解决了。

这次我在编译compizconfig-backend-gconf-0.6.0的时候

sudo ./configure然后碰到了

----

No package 'gconf-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GCONF_CFLAGS
and GCONF_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

----

我前几天我个个文件夹compiz相关的里面都给编译过都碰到了很多问题

这次是迎刃而解了。。。

sudo apt-get install libgconf2-dev

就可以解决No package 'gconf-2.0' found问题了 太棒了我要继续

编译compiz 0.6.0

Tags: ubuntu, 编译, compiz

No package 'libxslt' found

现在我又在编译compiz fusion 0.6.0了~

编译compiz-bcop-0.6.0的时候碰到的。

----------

No package 'libxslt' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBXSLT_CFLAGS
and LIBXSLT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

-----------

这个问题上次也碰到了 没给解决 这次自己用正则找

然后找到了libxslt-dev

马上用sudo apt-get install libxslt-dev

然后再次编译sudo ./configure哇靠竟然成功了~~哈哈高兴死了。。

继续编译去了

Tags: ubuntu, 编译, compiz

编译pidgin2.2.2 已成功一次性解决

编译了两次pidgin了。。然后得出了这个经验

省的下次或者你装的时候又碰到什么东西没有什么没有之类的。

西西写这个文章也是为了 音符这家伙阿~他还没有来得及编译呢。。

看了这个文章就能成功编译了。

---------

pidgin2.2.2下载地址:http://www.pidgin.im/download/source/

下载过来 解压出来 然后用终端进到你放置的目录 然后输入

sudo apt-get install libxml2-dev libgtk2.0-dev libglib2.0-dev gettext

把需要的包都给安装上 免得一次又一次出现 某某包没有被安装

OK等你把这些包下载更新完就开始编译pidgin2.2.2了!!!

输入sudo ./configure

编译成功后 再输入sudo make

最后输入sudo make install

嘿嘿编译的时候会有些慢 要有耐心哦!

Tags: pidgin, 编译

Pidgin 2.2.2 编译安装 You must have lib...

configure: error:

You must have libxml2 >= 2.6.0 development headers installed to build.

解决方法

sudo apt-get install libxml2-dev

Tags: pidgin, 编译

Pidgin 2.2.2 编译安装 You must have the...

configure: error:

You must have the GTK+ 2.0 development headers installed to compile pidgin.
If you only want to build Finch then specify --disable-gtkui when running configure.

解决方法

sudo apt-get install libgtk2.0-dev

Tags: pidgin, 编译

Pidgin 2.2.2 编译安装 You must have the...

configure: error:

You must have the GLib 2.0 development headers installed to build.

解决方法

sudo apt-get install libglib2.0-dev

Tags: pidgin, 编译

Pidgin 2.2.2 编译安装 The msgfmt comman...

The msgfmt command is required to build libpurple.  If it is installed
on your system, ensure that it is in your path.  If it is not, install
GNU gettext to continue.

If you have msgfmt installed, but for some reason this error message
is still displayed, you have encountered what appears to be a bug in
third-party configure macros.  Try setting the MSGFMT environment
variable to the absolute path to your msgfmt binary and trying
configure again, like this:

MSGFMT=/path/to/msgfmt ./configure ...

编译的时候出现了上面这个错误

在终端下输入sudo apt-get install gettext安装完即可解决

Tags: pidgin, 编译

error: Can't find X libraries.

编译fusion 0.6.0的时候碰到了下面这个问题

error: Can't find X libraries. Please check your installation and add the correct paths!

使用了下面这个命令就可以得到解放了

sudo apt-get install xorg-dev 

Tags: ubuntu, 编译

编译教程(转)不转我会后悔

从源码编译安装东东,不是很容易,想想在使用lfs之前,源码编译安装软件从来没
成功过,甚至出现错误都无从下手,只能放弃 
经过lfs的洗礼,总算对源码编译安装有了一点认识,可惜当初没有把这些经验写下来
不过现在开始写也不迟  将编译中遇到的问题及解决的方法记下来,积累经验

» 阅读全文

Tags: ubuntu, 编译

Total:20‹ Prev12